Comparar libros electrónicos

calibre incluye una herramienta integrada de comparación de libros electrónicos que se puede utilizar para ver lo que ha cambiado en el interior de un libro electrónico después de editarlo o convertirlo. Puede comparar libros en los formatos EPUB y AZW3.

Para usarla, sea abrir el libro en la herramienta para Modificar libros electrónicos y después pulse en Archivo > Comparar con otro libro o use el panel Detalles del libro. Si hace una conversion de EPUB a EPUB, el archivo EPUB original se guardará como ORIGINAL_EPUB. Simplemente pulse con el botón derecho en la entrada ORIGINAL_EPUB en el panel de los detalles del libro y seleccione Comparar con formato EPUB.

La herramienta de comparación que se abre será parecida a la siguiente imagen. Muestra las diferencias en el texto, estilos e imágenes entre los libros elegidos.

The compare tool

Comprender la vista de comparación

Como se puede ver en la imagen anterior, la vista de comparación muestra las diferencias entre los dos libros uno junto a otro. Sólo se muestran las diferencias con unas pocas líneas de contexto a su alrededor. Esto hace que sea fácil ver de un vistazo sólo lo que ha cambiado dentro de un documento de gran tamaño como un libro.

El texto añadido se muestra con un fondo verde, el texto eliminado con un fondo rojo y el texto modificado con un fondo azul.

Los números de línea de todo el texto modificado se muestran en los lados, por lo que es fácil desplazarse a un cambio determinado en el editor. Al abrir la herramienta de comparación desde el editor, también puede pulsar dos veces en una línea en el panel de la derecha para ir a esa línea en el editor de forma automática.

Una técnica útil cuando se comparan libros es decirle a la herramienta de comparación que embellezca los archivos de texto y estilo antes de calcular las diferencias. Esto a menudo puede resultar en diferencias más limpias y más faciles de seguir. Para ello, pulse en el botón :guilabel: Opciones en la parte inferior derecha y elija Embellecer los archivos antes de compararlos. Tenga en cuenta que el embellecimiento a veces puede tener efectos no deseados, ya que puede causar que un código no válido pase a ser válido. También puede cambiar el número de líneas de contexto que se muestran en torno a las diferencias mediante el botón :guilabel: Opciones.

Puede buscar cualquier texto en las diferencias a través de la barra de búsqueda en la parte inferior. Tendrá que especificar en qué panel buscar, el Izquierdo o el Derecho.

Iniciar la herramienta de comparación

La herramienta de comparación es más útil cuando se tienen dos versiones de un mismo libro y se desea ver lo que es diferente entre ellos. Hay varias formas de iniciar la herramienta.

Comparar dos archivos de libro electrónico

Abra el primer archivo en la herramienta Modificar libros electrónicos. Ahora pulse en Archivo > Comparar con otro libro y elija el segundo archivo (debe estar en el mismo formato que el primero). La vista de comparación se abrirá con el archivo que se está modificando a la derecha y el otro a la izquierda.

Comparar el ORIGINAL_FMT con FMT

Cuando realiza una conversión en calibre desde un FMT a sí mismo, el archivo original es guardado como ORIGINAL_FMT. Puede ver qué ha cambiado en la conversión, pulsando con el botón derecho en la entrada ORIGINAL_FMT en el panel Detalles del libro de la ventana principal de calibre y seleccionando Comparar con FMT. La vista de comparación se abrirá con el ORIGINAL_FMT a la izquierda y el FMT a la derecha.

Comparar un hito con el estado actual del libro durante su modificación

La herramienta Modificar libros electrónicos posee una función muy útil, llamada Hitos. Esto le permite guardar el estado actual de un libro como un hito, al cual puede retornar si no le agrada los cambios que ha hecho desde que se creó el hito. Estos hitos también se crean automáticamente cuando realizan algunas acciones automatizadas. Puede ver la lista de hitos en Ver > Hitos y después puede usar el botón Comparar para comparar el libro en el hito seleccionado con el estado actual. La herramienta de comparación mostrará el hito a la izquierda y el estado actual a la derecha.